
Creating a simple FLA file 

This tutorial guides you through the process of creating a basic FLA document. You'll use this workflow when 
authoring projects in Flash Professional. The first step involves creating a new document: 

1. open flash or Choose File > New. 
2. In the New Document dialog box, the ActionScript 3.0 file type is selected by default. Click OK. 

3. Click the Properties tab in the upper right side of the 
user interface to view the Property inspector, which 
displays the Stage properties for the file when no 
other objects are selected. 
 

4. By default, the Property inspector is vertically 
aligned along the right side of the workspace. The 
Size section displays the current Stage size setting as 
550 × 400 pixels (see Figure 4). The Stage 
background colour swatch is set to white. You can 
change the color of the Stage by clicking the swatch 
and selecting a different colour in the color picker 
that appears.  Pick any. 

 

Tip: You can set the background color of the Stage in the 
Flash movie by choosing Modify > Document or by 
selecting the Stage and then modifying the Stage color 
swatch in the Property inspector. There's no need to draw a 
rectangle to define the background color.  

6. Choose File > Save. 
7. Select the location to save the FLA (M:Drive). Name 

it SimpleFlash.fla and then click Save. Drawing a 
circle on the Stage 

After you've created your Flash document, you are ready to 
add some artwork to the project. Drawing shapes is a 
common task in Flash. When you use the drawing tools in 
the Tools panel, the vector graphics you create can be edited at any time. The following steps describe how to 
create a circle; later, you'll use this circle to create some basic animation. 
Follow these steps: 

1. Select the Oval tool from the Tools panel (it may be hidden in the 
rectangle docker). 

2. Use the stroke color swatch in the Property inspector to select the No 
Color option (red diagonal stripe) from the Stroke Color Picker (see 
below). 

 
 
 
 



3. Select a color of your choice from the Fill color picker, located directly 
below the Stroke color picker. Choose a fill color that contrasts well with 
the Stage color. In this example, an oval with a blue fill color is displayed 
on top of a red Stage color. 
 

4. Whenever you draw a vector shape, you have the option of selecting two 
drawing modes: Merge drawing mode and Object drawing mode. For the 
purposes of this tutorial, click the drawing mode button to select the 
Object drawing mode at the very bottom of the Tools panel. When the 
Object drawing mode is selected, the button will appear darker and 
selected, as shown left. 

 
Figure left. The Drawing mode button is a toggle that alternates between modes; 

choose Object drawing mode by clicking the button to make its background appear darker.  

5. While the Oval tool still selected, press and hold the 
Shift key. Draw a circle on the Stage by Shift-
dragging on the Stage .   The Shift key is a modifier 
key; when you press and hold the Shift key while 
drawing or transforming a shape with the Oval tool, 
Flash constrains the Oval tool shape to a circle that 
is perfectly symmetrical. 

Note: The Shift key works similarly with other auto 
shapes; when you press and hold Shift while drawing a 
shape with the Rectangle tool, you'll create a perfect 
square. 

 

Creating a symbol and adding animation  

After drawing some artwork, you can turn it into a reusable asset by converting it to a symbol. A symbol is a 
media asset that can be reused anywhere in your document without the need to re-create it. Symbols can contain 
bitmap and vector images and animations, along with other types of content. 

It is common to use symbols to create tweened animations. As you become more familiar with Flash 
Professional, you'll use symbols to structure applications and interactivity using multiple timelines. Symbols are 
useful for compartmentalizing parts of a project to make it easier for you to edit specific sections later. Follow 
these steps to create a symbol: 

1. Click the Selection tool in the Tools panel  

2. Click the circle on the Stage to select it.  
 

3. While the circle is still selected, choose Modify > 
Convert to Symbol (or press F8) to access the 
Convert to Symbol dialog box. Enter the name of 
the symbol in the Name field. Use the Type menu 
to select the Movie Clip option. 

Tip: You can also convert a graphic into a symbol by selecting it and dragging it into the Library panel. 



 

4. Click OK. A square bounding box is displayed around the circle symbol. You've just created a reusable 
asset, called a symbol, in your document. In this case, you created a movie clip symbol named 
my_circle. (For more information about symbols, read Working with symbols in the Flash Professional 
online documentation.) 

If the Library panel is not open, choose Window > Library to access it. The new symbol is now listed in the 
Library panel. (When you drag a copy of the symbol from the Library panel to the Stage, the copy on the Stage 
is called an instance of the symbol.) 

Animating the circle 

In this section, you'll use the symbol in your 
document to create a basic animation that moves 
across the Stage: 

1. Select the circle on the Stage and drag it off 
the Stage area to the left  

2. Right-click the circle instance on the Stage 
and choose the option to Create Motion 
Tween in the menu that appears. Notice that 
the Timeline is automatically extended to 
Frame 24 and the red marker (the current 
frame indicator, also known as the playhead) 
moves to Frame 24.  
This indicates that the Timeline 
is prepared for you to edit the 
ending location of the symbol 
and create a one-second 
animation—assuming that you 
haven't changed default frame 
rate for the project from 24 fps in 
the Property inspector. A span of 
24 frames is the equivalent of 
one second at a rate of 24 fps.  

3. While the playhead is still on Frame 24 of the 
Timeline, select the circle instance on the Stage and 
drag it to the right, just past the Stage area. This 
step of relocating the instance creates a tweened 
animation. On Frame 24, notice the diamond-
shaped dot (known as a property keyframe) that 
appears. On the Stage, also notice the motion guide 
that indicates the circle's path of motion between 
Frame 1 and Frame 24 . 

 
 
 
 



4. In the Timeline, drag the red playhead back and forth from Frame 1 to Frame 24 to preview the 
animation; this is known as scrubbing the Timeline. 

 

5. You can change the circle's direction in the 
middle of the animation. First, drag the 
playhead to Frame 10 in the Timeline. Then 
select the circle and move it to another location, 
further down on the Stage. Notice that the 
change is reflected in the motion guide and the 
new dot (property keyframe) appears on Frame 
10 of the Timeline. The property keyframes on 
the Timeline mark the timing of the animation, 
indicating the frames whenever objects change 
on the screen and storing the properties of the 
object that change. In this example, it is the 
circle's location on the Stage (known as its X 
and Y or horizontal and vertical) properties that 
are changing as the playhead moves across the 
Timeline. 

6. Experiment with editing the animation by 
changing the shape of the motion guide path. 
Click the Selection tool in the Tools panel and 
then click a section of the motion guide line. 
Drag it to bend the line shape When you bend 
the motion path, you cause the animation to 
follow along a smooth curved line instead of a 
rigid straight line. 

 

7. Choose Control > Test Movie to test the FLA 
file and watch the animation play back in Flash 
Player. 

 

8. The movie loops automatically, so you can watch the circle move across the window repeatedly. When 
you are finished, close the Test Movie window. 

Using a stop action to stop the Timeline from looping 

When you tested the movie, the animation loops by default as the movie plays in Flash Player. This occurs 
automatically because in Flash Professional, the Timeline is set up to loop back to Frame 1 after exiting the last 
frame—unless you instruct the movie to do otherwise. When you want to add a command that controls the 
Timeline, you'll add ActionScript code to a keyframe (indicated by a dot symbol) on the Timeline. This is 
known as adding a frame script. 

Tip: Keyframes are used to place ActionScript and assets on specific frames in the Timeline. When you review 
the Timeline of a FLA file, you can locate scripts and content by looking for the keyframe dots. Keyframes that 
have frame scripts display a lower case "a" symbol. 



Follow the steps below to add ActionScript code to your FLA file. You'll add one of the most common 
Timeline commands, which is called the stop action: 

1. It's always a good idea to name your layers if you have more than one. A large project can quickly 
become unmanageable if its layers are not descriptively named. Double-click the name to rename Layer 
1. In the field that appears, enter the new name: animation. 

2. Click the New Layer button (page icon) in the lower left of the Timeline panel. In an ActionScript 3 file, 
the ActionScript code must be added to the Timeline. It's considered best practice to create a layer 
named actions at the top of the layer stack, dedicated to holding the ActionScript code. Rename the new 
layer you just created to: actions. Make sure it is located above the animation layer. Now that you've 
created a layer to place your scripts, you can add keyframes to the actions layer to associate the 
ActionScript code with specific frames. 

3. Move the playhead to Frame 24. Click the actions layer at Frame 24 (to highlight the last frame on the 
actions layer). Insert a keyframe on Frame 24 of the actions layer by choosing Insert > Timeline > 
Keyframe (or pressing F6). Notice that an empty, blank keyframe appears (you can tell that the new 
keyframe doesn't contain any graphics because the dot icon for the keyframe is hollow, rather than 
displaying a solid color). 

4. Select the new keyframe with the Selection tool. Open the Actions panel (Window > Actions). The 
Actions panel contains the Script window, which is a large text field you'll use to type or paste 
ActionScript code directly into your FLA file. Place your cursor in the text area next to the number 1 
(line 1) and type in the following action: 

stop();  

5. After typing the line of ActionScript 
code in the Script window, you'll 
notice that a little "a" icon appears 
above the keyframe in the actions layer 
of the Timeline. This indicates that the 
keyframe contains a frame script (also 
known as an action). At this point, 
your Timeline should look similar to 
the picture right. Close the Actions 
panel. If you need to edit the code, you 
can always select the keyframe in the Timeline and then open the Actions panel again. 
 

6. Choose Control > Test Movie to test the FLA file and watch it play in Flash Player. Notice that this 
time, the animation doesn't loop. You can return to Flash and test the movie again to watch the movie 
play again. 

7. When you are finished previewing the animation, close the Test Movie window. 
8. Back in Flash, save the FLA file. 

Adding a replay button to restart the animation 

In an earlier section, you stopped the animation from looping by adding a stop() action to the last frame of the 
Timeline. When the playhead reaches the last frame, it is instructed to stop, which prevents it from looping back 
to Frame 1. 

In this set of instructions, you'll learn how to add a Replay button. When a user clicks the button, it causes the 
playhead to begin playing from Frame 1 again. Flash is extremely flexible. There are many strategies that you 
could use to create a Replay button, including restarting the playhead when a user presses a key on their 
keyboard, or when they click on the Stage, or when they click a button. To achieve any of these options, you'll 



add some ActionScript code that responds to the user interactivity at runtime (while the SWF file is playing). 
This section is a little more advanced than the previous sections—it covers some new concepts that you'll use to 
control the behavior of your Flash movies with programming. 

Follow these steps to add a Replay button and the corresponding ActionScript to your file: 

1. In Flash, it is a best practice to create a new layer for each element in the project (with the exception of 
ActionScript code, which can be placed on any frame on the top-level actions layer). Click the New 
Layer button (page icon) in the Timeline to create a new layer for the button graphic. Double-click the 
default layer name and rename it: Button.  Move this layer by dragging it below the actions layer. 
 

2. Open the Components panel (Window > Components) and drag a button component from the User 
Interface Components folder to the Stage. Position the button in the lower middle of the Stage area, or 
any desired location. 
 

3. While the Button component still selected, open the Property inspector and locate the text field at the top 
named <Instance Name>. Enter the name for the button instance:  replay_btn. This is an important step. 
By naming the button instance, you'll be able to reference it by name using the ActionScript you'll add to 
the project. If the button instance's name does not exactly match the button's name specified in the code, 
the behavior won't function as expected. 
 

4. To update the text label of the button that is displayed on the Stage you will 
need to have the button selected, go to the window menu up  top and choose 
“component inspector” enter the text Replay into the label field  
This label helps users understand what the button will do. It is purely visual and does not affect the 
performance of the code. If you'd prefer that the button display a different label, you could enter 
Rewind, Again, or a different label of your choosing. 
 

5. Select the keyframe on Frame 1 of the actions layer. Open the Actions panel 
(Window > Actions). Copy the code snippet below and paste it into the 
Script window: 

import flash.events.MouseEvent; 
   
function onClick(event:MouseEvent):void 
{ 
   gotoAndPlay(1); 
} 
replay_btn.addEventListener(MouseEvent.CLICK, onClick);  
 

6. Take a few moments to read through the code. Notice that the second line begins by declaring a 
functionnamed onClick. The last line of code uses theaddEventListener method, which registers the 
function as an "event listener" for the button's "click" event. The translation of this code essentially says: 
"When a user clicks the button named replay_btn, run the function named onClick. When the onClick 
function runs, it instructs the playhead to jump to Frame 1 of the Timeline and begin playing the 
frames." 

7. Choose Control > Test Movie to test the FLA file. The animation plays once and then stops. Click the 
Replay button to restart the animation and watch the circle move across the Stage again. 

8. Close the Test Movie window and save your FLA file. 



Add Sound effects 

Flash® CS4 Professional offers several ways to use sound. Make sounds that play continuously, independent of the Timeline, or use 

the Timeline to synchronize animation to a sound track. Add sounds to buttons to make them more interactive, and make sounds 

fade in and out for a more polished sound track. 

There are two types of sounds in Flash: event sounds and stream sounds. An event sound must download completely before it 

begins playing, and it continues playing until explicitly stopped. Stream sounds begin playing as soon as enough data for the first 

few frames has been downloaded; stream sounds are synchronized to the Timeline for playing on a website 

You place sound files into Flash by importing them into the library for the current document. 

1. Select File > Import > Import To Library. 

2. In the Import dialog box, locate and open the desired sound file. 

            You need only one copy of a sound file to use that sound multiple times/ ways in your document.  

3. Insert a new layer. Name it bounce sound and be sure to place the layer below the actions layer. 

4. With the new sound layer selected, drag the sound from the Library panel onto the Stage. The sound is added to the current 

layer.  

            It is recommended that each sound be placed on a separate layer. Each layer acts as a separate sound channel.  

5. You’ll notice that the sound file is located at the beginning of your animation and not where the ball hits the ground.  Its 

simple to move, select frame one of the bounce sound layer and drag it to frame 10 so it is in line with the ball hitting the ground. 

Test and save your animation 

Add a sound to a button 
1. Add a “click” sound to your library 

2. double click on your button to get into it’s properties.  
3. Double click on down to add a sound to that event 

4. In the down button’s Timeline, add a layer for sound (Insert > Timeline > Layer).  

5. Name the layer “click” 

6. Select the frame of that layer and drag your click sound from the library onto the stage. 

7. Return to your scene by choosing scene 1 and test your animation 

 


